From: | Maxim Orlov <orlovmg(at)gmail(dot)com> |
---|---|
To: | Andrey Borodin <x4mmm(at)yandex-team(dot)ru> |
Cc: | Michael Paquier <michael(at)paquier(dot)xyz>, "Maksim(dot)Melnikov" <m(dot)melnikov(at)postgrespro(dot)ru>, PostgreSQL Hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org>, Heikki Linnakangas <hlinnaka(at)iki(dot)fi>, Jelte Fennema-Nio <postgres(at)jeltef(dot)nl> |
Subject: | Re: Spinlock can be released twice in procsignal.c |
Date: | 2025-02-26 09:33:16 |
Message-ID: | CACG=ezbD9sryj+8SjGXPC0PHB-z_6NW6J9RSfXqtXRDFXPv+uQ@mail.gmail.com |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
On Wed, 26 Feb 2025 at 11:26, Andrey Borodin <x4mmm(at)yandex-team(dot)ru> wrote:
>
> I’d suggest to give some more descriptive name to “logit” and expand
> comment “/* sanity check */“. This comment was easier to understand when
> elog() was near, but now IMO we can have few words about what is going on.
Done. Except for a new name for "logit" variable. Unfortunately, I can't
think of anything sane. As an example I looked at sequence.c. The same name
is used there. I will gladly change this name to whatever you want if it
still look misleading or incomplete for you in some way or another. Just
write the name that you think is correct.
--
Best regards,
Maxim Orlov.
Attachment | Content-Type | Size |
---|---|---|
v3-0001-Avoid-double-spinlock-release.patch | application/octet-stream | 2.0 KB |
From | Date | Subject | |
---|---|---|---|
Next Message | Bertrand Drouvot | 2025-02-26 09:40:08 | Re: Doc fix of aggressive vacuum threshold for multixact members storage |
Previous Message | Corey Huinker | 2025-02-26 09:25:29 | Re: Statistics Import and Export |