From: | Peter Smith <smithpb2250(at)gmail(dot)com> |
---|---|
To: | Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> |
Cc: | PostgreSQL Hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org> |
Subject: | Re: Propose a new function - list_is_empty |
Date: | 2022-08-16 01:39:25 |
Message-ID: | CAHut+PsZTZXOjymooviD99jEdw6BYxYdD29Yg3C=VuUkOx1EtQ@mail.gmail.com |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
On Tue, Aug 16, 2022 at 11:27 AM Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
>
> Peter Smith <smithpb2250(at)gmail(dot)com> writes:
> > During a recent code review I was going to suggest that some new code
> > would be more readable if the following:
> > if (list_length(alist) == 0) ...
>
> > was replaced with:
> > if (list_is_empty(alist)) ...
>
> > but then I found that actually no such function exists.
>
> That's because the *correct* way to write it is either "alist == NIL"
> or just "!alist". I don't think we need yet another way to spell
> that, and I'm entirely not on board with replacing either of those
> idioms. But if you want to get rid of overcomplicated uses of
> list_length() in favor of one of those spellings, have at it.
>
Thanks for your advice.
Yes, I saw that NIL is the definition of an empty list - that's how I
implemented list_is_empty.
OK, I'll ditch the function idea and just look at de-complicating
those existing empty List checks.
------
Kind Regards,
Peter Smith.
Fujitsu Australia
From | Date | Subject | |
---|---|---|---|
Next Message | John Naylor | 2022-08-16 01:48:27 | Re: fix typos |
Previous Message | Tom Lane | 2022-08-16 01:27:56 | Re: Propose a new function - list_is_empty |