Peter Smith <smithpb2250(at)gmail(dot)com> writes:
> During a recent code review I was going to suggest that some new code
> would be more readable if the following:
> if (list_length(alist) == 0) ...
> was replaced with:
> if (list_is_empty(alist)) ...
> but then I found that actually no such function exists.
That's because the *correct* way to write it is either "alist == NIL"
or just "!alist". I don't think we need yet another way to spell
that, and I'm entirely not on board with replacing either of those
idioms. But if you want to get rid of overcomplicated uses of
list_length() in favor of one of those spellings, have at it.
regards, tom lane