From: | Nisha Moond <nisha(dot)moond412(at)gmail(dot)com> |
---|---|
To: | Peter Smith <smithpb2250(at)gmail(dot)com> |
Cc: | Shlok Kyal <shlok(dot)kyal(dot)oss(at)gmail(dot)com>, Amit Kapila <amit(dot)kapila16(at)gmail(dot)com>, vignesh C <vignesh21(at)gmail(dot)com>, "Hayato Kuroda (Fujitsu)" <kuroda(dot)hayato(at)fujitsu(dot)com>, shveta malik <shveta(dot)malik(at)gmail(dot)com>, Bharath Rupireddy <bharath(dot)rupireddyforpostgres(at)gmail(dot)com>, Ajin Cherian <itsajin(at)gmail(dot)com>, Bertrand Drouvot <bertranddrouvot(dot)pg(at)gmail(dot)com>, Masahiko Sawada <sawada(dot)mshk(at)gmail(dot)com>, Nathan Bossart <nathandbossart(at)gmail(dot)com>, PostgreSQL Hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org> |
Subject: | Re: Introduce XID age and inactive timeout based replication slot invalidation |
Date: | 2025-01-22 05:19:28 |
Message-ID: | CABdArM6JWkkVY9wN-Vo1y-e6sf3cYazsPnm07kPfbDufRiBjqw@mail.gmail.com |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
On Tue, Jan 21, 2025 at 8:22 AM Peter Smith <smithpb2250(at)gmail(dot)com> wrote:
>
> Some review comments for patch v61-0001.
>
> ======
> src/backend/replication/slot.c
>
> InvalidatePossiblyObsoleteSlot:
>
> 1.
> /*
> * Check if the slot needs to be invalidated. If it needs to be
> - * invalidated, and is not currently acquired, acquire it and mark it
> - * as having been invalidated. We do this with the spinlock held to
> - * avoid race conditions -- for example the restart_lsn could move
> - * forward, or the slot could be dropped.
> + * invalidated, and is already ours, mark it as having been
> + * invalidated; otherwise, acquire it first and then mark it as having
> + * been invalidated. We do this with the spinlock held to avoid race
> + * conditions -- for example the restart_lsn could move forward, or
> + * the slot could be dropped.
> */
>
> Can't you just word this as "mark it as invalidated" (which you do
> later anyway) instead of "mark is as having been invalidated"? (this
> is in two places).
>
Thanks for pointing it out, I had considered it but was trying to keep
the language consistent with the previous style. I've now made the
change in v62.
> ~~~
>
> 2.
> + /*
> + * The logical replication slots shouldn't be invalidated as GUC
> + * max_slot_wal_keep_size is set to -1 during the binary upgrade.
> + * See check_old_cluster_for_valid_slots() where we ensure that no
> + * invalidated before the upgrade.
> + */
> + Assert(!(*invalidated && SlotIsLogical(s) && IsBinaryUpgrade));
>
> 2a.
> I know this sentence was the same before you moved it, but "ensure
> that no invalidated" seems like there are some words missing.
>
Corrected.
> 2b.
> TBH, I this part confused me (the code is repeated in a couple of
> places). AFAICT the code/comment does not match quite right. The
> comment refers to a setting that is "during binary upgrade", yet the
> Assert can only pass if IsBinaryUpgrade is false. (??)
>
> I'm unsure of the intent; perhaps it should be like:
>
> if (IsBinaryUpgrade)
> Assert(!(*invalidated && SlotIsLogical(s)));
>
This Assert condition is correct, as we don’t want to invalidate slots
during a binary upgrade and it only triggers(raise error) when all
three conditions are true, meaning when 'IsBinaryUpgrade' is also
true.
That said, I agree with your point that we are unnecessarily checking
"(*invalidated && SlotIsLogical(s))" even when not in binary upgrade
mode.
To optimize this, we can first check 'IsBinaryUpgrade' before
evaluating the other conditions:
Assert(!(IsBinaryUpgrade && *invalidated && SlotIsLogical(s)));
- Since 'IsBinaryUpgrade' is 'false' most of the time, this approach
short-circuits evaluation, making it more efficient.
However, if you feel that this condition isn’t as clear to read or
understand, we can separate the 'IsBinaryUpgrade' check outside the
'Assert', as you suggested. Let me know what you think!
--
Thanks,
Nisha
From | Date | Subject | |
---|---|---|---|
Next Message | Michael Paquier | 2025-01-22 05:50:47 | Re: pg_createsubscriber TAP test wrapping makes command options hard to read. |
Previous Message | Nisha Moond | 2025-01-22 05:16:45 | Re: Introduce XID age and inactive timeout based replication slot invalidation |