From: | Yugo NAGATA <nagata(at)sraoss(dot)co(dot)jp> |
---|---|
To: | Peter Eisentraut <peter(at)eisentraut(dot)org> |
Cc: | pgsql-hackers <pgsql-hackers(at)postgresql(dot)org> |
Subject: | Re: Rename libpq trace internal functions |
Date: | 2024-04-24 10:34:22 |
Message-ID: | 20240424193422.ef3ea25136e665448852a8fa@sraoss.co.jp |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
On Wed, 24 Apr 2024 09:39:02 +0200
Peter Eisentraut <peter(at)eisentraut(dot)org> wrote:
> libpq's pqTraceOutputMessage() used to look like this:
>
> case 'Z': /* Ready For Query */
> pqTraceOutputZ(conn->Pfdebug, message, &logCursor);
> break;
>
> Commit f4b54e1ed98 introduced macros for protocol characters, so now
> it looks like this:
>
> case PqMsg_ReadyForQuery:
> pqTraceOutputZ(conn->Pfdebug, message, &logCursor);
> break;
>
> But this introduced a disconnect between the symbol in the switch case
> and the function name to be called, so this made the manageability of
> this file a bit worse.
>
> This patch changes the function names to match, so now it looks like
> this:
>
> case PqMsg_ReadyForQuery:
> pqTraceOutput_ReadyForQuery(conn->Pfdebug, message, &logCursor);
> break;
+1
I prefer the new function names since it seems more natural and easier to read.
I noticed pqTraceOutputNR() is left as is, is this intentional? Or, shoud this
be changed to pqTranceOutput_NoticeResponse()?
Regards,
Yugo Nagata
> (This also improves the readability of the file in general, since some
> function names like "pqTraceOutputt" were a little hard to read
> accurately.)
>
> Some protocol characters have different meanings to and from the
> server. The old code structure had a common function for both, for
> example, pqTraceOutputD(). The new structure splits this up into
> separate ones to match the protocol message name, like
> pqTraceOutput_Describe() and pqTraceOutput_DataRow().
--
Yugo NAGATA <nagata(at)sraoss(dot)co(dot)jp>
From | Date | Subject | |
---|---|---|---|
Next Message | Andrew Dunstan | 2024-04-24 10:37:00 | Re: Why does pgindent's README say to download typedefs.list from the buildfarm? |
Previous Message | Peter Eisentraut | 2024-04-24 10:30:30 | Re: doc: create table improvements |