From: | Peter Eisentraut <peter(dot)eisentraut(at)2ndquadrant(dot)com> |
---|---|
To: | pgsql-hackers <pgsql-hackers(at)postgresql(dot)org> |
Subject: | warn_unused_results |
Date: | 2020-10-17 06:57:51 |
Message-ID: | e3753562-99cd-b65f-5aca-687dfd1ec2fc@2ndquadrant.com |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
Forgetting to assign the return value of list APIs such as lappend() is
a perennial favorite. The compiler can help point out such mistakes.
GCC has an attribute warn_unused_results. Also C++ has standardized
this under the name "nodiscard", and C has a proposal to do the same
[0]. In my patch I call the symbol pg_nodiscard, so that perhaps in a
distant future one only has to do s/pg_nodiscard/nodiscard/ or something
similar. Also, the name is short enough that it doesn't mess up the
formatting of function declarations too much.
I have added pg_nodiscard decorations to all the list functions where I
found it sensible, as well as repalloc() for good measure, since
realloc() is usually mentioned as an example where this function
attribute is useful.
I have found two places in the existing code where this creates
warnings. Both places are correct as is, but make assumptions about the
internals of the list APIs and it seemed better just to fix the warning
than to write a treatise about why it's correct as is.
[0]: http://www.open-std.org/jtc1/sc22/wg14/www/docs/n2051.pdf
--
Peter Eisentraut http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services
Attachment | Content-Type | Size |
---|---|---|
0001-Add-pg_nodiscard-function-declaration-specifier.patch | text/plain | 1.3 KB |
0002-Add-pg_nodiscard-decorations-to-some-functions.patch | text/plain | 6.5 KB |
0003-Silence-some-pg_nodiscard-warnings.patch | text/plain | 1.6 KB |
From | Date | Subject | |
---|---|---|---|
Next Message | Amit Langote | 2020-10-17 07:44:56 | Re: partition routing layering in nodeModifyTable.c |
Previous Message | Dilip Kumar | 2020-10-17 06:04:05 | Re: [HACKERS] Custom compression methods |