From: | "David E(dot) Wheeler" <david(at)justatheory(dot)com> |
---|---|
To: | Brendan Jurd <direvus(at)gmail(dot)com> |
Cc: | Merlin Moncure <mmoncure(at)gmail(dot)com>, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>, Josh Berkus <josh(at)agliodbs(dot)com>, pgsql-hackers(at)postgresql(dot)org |
Subject: | Re: [PATCH] Exorcise "zero-dimensional" arrays (Was: Re: Should array_length() Return NULL) |
Date: | 2013-06-13 17:53:56 |
Message-ID: | FF060A90-9E7C-4980-88CF-B80F7B1A4D7A@justatheory.com |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
On Jun 12, 2013, at 8:00 PM, Brendan Jurd <direvus(at)gmail(dot)com> wrote:
> array_dims - Returns the dimensions of the array, unless it is empty
> in which case NULL.
> array_proper_dims - Returns the dimensions of the array.
> array_ndims - Returns the number of dimension, unless it is empty in
> which case NULL.
> array_proper_ndims - Returns the number of dimensions.
>
> ... and so on for _length, _upper and _lower.
Similar things should have dissimilar names. I propose:
<bikeshedding>
Old | New
--------------+--------------
array_dims | array_desc
array_ndims | array_depth
array_length | array_size
array_lower | array_start
array_upper | array_finish
The last two are meh, but it’s a place to start…
</bikeshedding>
David
From | Date | Subject | |
---|---|---|---|
Next Message | Fujii Masao | 2013-06-13 19:38:57 | Re: Clean switchover |
Previous Message | David E. Wheeler | 2013-06-13 17:36:40 | Re: [PATCH] Remove useless USE_PGXS support in contrib |