pgsql: Rename pg_constraint.conwithoutoverlaps to conperiod

From: Peter Eisentraut <peter(at)eisentraut(dot)org>
To: pgsql-committers(at)lists(dot)postgresql(dot)org
Subject: pgsql: Rename pg_constraint.conwithoutoverlaps to conperiod
Date: 2024-03-05 10:28:50
Message-ID: E1rhS2U-002C8Z-HH@gemulon.postgresql.org
Views: Raw Message | Whole Thread | Download mbox | Resend email
Thread:
Lists: pgsql-committers

Rename pg_constraint.conwithoutoverlaps to conperiod

pg_constraint.conwithoutoverlaps was recently added to support primary
keys and unique constraints with the WITHOUT OVERLAPS clause. An
upcoming patch provides the foreign-key side of this functionality,
but the syntax there is different and uses the keyword PERIOD. It
would make sense to use the same pg_constraint field for both of
these, but then we should pick a more general name that conveys "this
constraint has a temporal/period-related feature". conperiod works
for that and is nicely compact. Changing this now avoids possibly
having to introduce versioning into clients. Note there are still
some "without overlaps" variables left, which deal specifically with
the parsing of the primary key/unique constraint feature.

Author: Paul A. Jungwirth <pj(at)illuminatedcomputing(dot)com>
Discussion: https://www.postgresql.org/message-id/flat/CA+renyUApHgSZF9-nd-a0+OPGharLQLO=mDHcY4_qQ0+noCUVg(at)mail(dot)gmail(dot)com

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/030e10ff1a365796bd4bcbbc5b6a8552f7efc765

Modified Files
--------------
doc/src/sgml/catalogs.sgml | 2 +-
src/backend/catalog/heap.c | 4 ++--
src/backend/catalog/pg_constraint.c | 4 ++--
src/backend/commands/tablecmds.c | 6 +++---
src/backend/commands/trigger.c | 2 +-
src/backend/commands/typecmds.c | 2 +-
src/backend/utils/adt/ruleutils.c | 2 +-
src/backend/utils/cache/relcache.c | 6 +++---
src/bin/pg_dump/pg_dump.c | 12 ++++++------
src/bin/pg_dump/pg_dump.h | 3 +--
src/bin/psql/describe.c | 4 ++--
src/include/catalog/catversion.h | 2 +-
src/include/catalog/pg_constraint.h | 4 ++--
13 files changed, 26 insertions(+), 27 deletions(-)

Browse pgsql-committers by date

  From Date Subject
Next Message Alvaro Herrera 2024-03-05 11:11:46 pgsql: Rework redundant code in subtrans.c
Previous Message Heikki Linnakangas 2024-03-05 07:15:29 pgsql: Fix a leftover reference to backend_id in comment