pgsql: Improve confusing variable names

From: Peter Eisentraut <peter(at)eisentraut(dot)org>
To: pgsql-committers(at)lists(dot)postgresql(dot)org
Subject: pgsql: Improve confusing variable names
Date: 2021-02-02 08:33:13
Message-ID: E1l6r7Z-0004yV-J1@gemulon.postgresql.org
Views: Raw Message | Whole Thread | Download mbox | Resend email
Thread:
Lists: pgsql-committers

Improve confusing variable names

The prototype calls the second argument of
pgstat_progress_update_multi_param() "index", and some callers name
their local variable that way. But when the surrounding code deals
with index relations, this is confusing, and in at least one case
shadowed another variable that is referring to an index relation.
Adjust those call sites to have clearer local variable naming, similar
to existing callers in indexcmds.c.

Branch
------
master

Details
-------
https://git.postgresql.org/pg/commitdiff/1d71f3c83c113849fe3aa60cb2d2c12729485e97

Modified Files
--------------
src/backend/access/nbtree/nbtsort.c | 6 +++---
src/backend/catalog/index.c | 18 +++++++++---------
2 files changed, 12 insertions(+), 12 deletions(-)

Browse pgsql-committers by date

  From Date Subject
Next Message Tom Lane 2021-02-02 18:49:28 pgsql: Fix ancient memory leak in contrib/auto_explain.
Previous Message Michael Paquier 2021-02-02 05:00:14 pgsql: Remove unused column atttypmod from initial tablesync query