From: | Robert Haas <rhaas(at)postgresql(dot)org> |
---|---|
To: | pgsql-committers(at)postgresql(dot)org |
Subject: | pgsql: Remove all references to "xlog" from SQL-callable functions in p |
Date: | 2017-02-09 20:36:04 |
Message-ID: | E1cbvRk-0004Em-VD@gemulon.postgresql.org |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-committers pgsql-hackers |
Remove all references to "xlog" from SQL-callable functions in pg_proc.
Commit f82ec32ac30ae7e3ec7c84067192535b2ff8ec0e renamed the pg_xlog
directory to pg_wal. To make things consistent, and because "xlog" is
terrible terminology for either "transaction log" or "write-ahead log"
rename all SQL-callable functions that contain "xlog" in the name to
instead contain "wal". (Note that this may pose an upgrade hazard for
some users.)
Similarly, rename the xlog_position argument of the functions that
create slots to be called wal_position.
Discussion: https://www.postgresql.org/message-id/CA+Tgmob=YmA=H3DbW1YuOXnFVgBheRmyDkWcD9M8f=5bGWYEoQ@mail.gmail.com
Branch
------
master
Details
-------
http://git.postgresql.org/pg/commitdiff/806091c96f9b81f7631e4e37a05af377b473b5da
Modified Files
--------------
contrib/bloom/t/001_wal.pl | 2 +-
contrib/test_decoding/expected/ddl.out | 2 +-
contrib/test_decoding/sql/ddl.sql | 2 +-
doc/src/sgml/backup.sgml | 2 +-
doc/src/sgml/func.sgml | 72 +++++++++++-----------
doc/src/sgml/high-availability.sgml | 14 ++---
doc/src/sgml/logicaldecoding.sgml | 2 +-
doc/src/sgml/recovery-config.sgml | 2 +-
src/backend/access/transam/recovery.conf.sample | 2 +-
src/backend/access/transam/xlog.c | 2 +-
src/backend/access/transam/xlogfuncs.c | 36 +++++------
src/backend/catalog/system_views.sql | 10 +--
src/bin/pg_basebackup/t/030_pg_recvlogical.pl | 2 +-
src/bin/pg_rewind/RewindTest.pm | 2 +-
src/bin/pg_rewind/libpq_fetch.c | 4 +-
src/include/catalog/catversion.h | 2 +-
src/include/catalog/pg_proc.h | 54 ++++++++--------
src/test/modules/commit_ts/t/002_standby.pl | 8 +--
src/test/modules/commit_ts/t/003_standby_2.pl | 4 +-
src/test/perl/PostgresNode.pm | 10 +--
src/test/recovery/t/002_archiving.pl | 6 +-
src/test/recovery/t/003_recovery_targets.pl | 16 ++---
src/test/recovery/t/005_replay_delay.pl | 4 +-
src/test/recovery/t/008_fsm_truncation.pl | 4 +-
src/test/regress/expected/hs_standby_functions.out | 2 +-
src/test/regress/sql/hs_primary_extremes.sql | 2 +-
src/test/regress/sql/hs_primary_setup.sql | 2 +-
src/test/regress/sql/hs_standby_functions.sql | 2 +-
src/test/subscription/t/001_rep_changes.pl | 2 +-
src/test/subscription/t/002_types.pl | 2 +-
30 files changed, 138 insertions(+), 138 deletions(-)
From | Date | Subject | |
---|---|---|---|
Next Message | Tom Lane | 2017-02-09 20:50:27 | pgsql: Blind try to fix portability issue in commit 8f93bd851 et al. |
Previous Message | Robert Haas | 2017-02-09 20:05:04 | pgsql: simplehash: Additional tweaks to make specifying an allocator wo |
From | Date | Subject | |
---|---|---|---|
Next Message | Josh Berkus | 2017-02-09 20:37:49 | Re: [PATCH] Rename pg_switch_xlog to pg_switch_wal |
Previous Message | Kevin Grittner | 2017-02-09 20:33:05 | Re: [PATCH] Rename pg_switch_xlog to pg_switch_wal |