pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid

From: Joe Conway <mail(at)joeconway(dot)com>
To: pgsql-committers(at)postgresql(dot)org
Subject: pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid
Date: 2015-12-28 20:35:56
Message-ID: E1aDeWK-00033i-Rb@gemulon.postgresql.org
Views: Raw Message | Whole Thread | Download mbox | Resend email
Thread:
Lists: pgsql-committers

Rename (new|old)estCommitTs to (new|old)estCommitTsXid

The variables newestCommitTs and oldestCommitTs sound as if they are
timestamps, but in fact they are the transaction Ids that correspond
to the newest and oldest timestamps rather than the actual timestamps.
Rename these variables to reflect that they are actually xids: to wit
newestCommitTsXid and oldestCommitTsXid respectively. Also modify
related code in a similar fashion, particularly the user facing output
emitted by pg_controldata and pg_resetxlog.

Complaint and patch by me, review by Tom Lane and Alvaro Herrera.
Backpatch to 9.5 where these variables were first introduced.

Branch
------
master

Details
-------
http://git.postgresql.org/pg/commitdiff/241448b23adf3432988f2b4012ff90a338b4d0bf

Modified Files
--------------
src/backend/access/rmgrdesc/xlogdesc.c | 4 +--
src/backend/access/transam/commit_ts.c | 52 +++++++++++++++----------------
src/backend/access/transam/xlog.c | 16 +++++-----
src/backend/commands/vacuum.c | 2 +-
src/bin/pg_controldata/pg_controldata.c | 8 ++---
src/bin/pg_resetxlog/pg_resetxlog.c | 44 +++++++++++++-------------
src/include/access/commit_ts.h | 2 +-
src/include/access/transam.h | 4 +--
src/include/catalog/pg_control.h | 4 +--
9 files changed, 68 insertions(+), 68 deletions(-)

Browse pgsql-committers by date

  From Date Subject
Next Message Joe Conway 2015-12-28 20:35:59 pgsql: Rename (new|old)estCommitTs to (new|old)estCommitTsXid
Previous Message Tom Lane 2015-12-28 19:39:23 pgsql: Code and docs review for cube kNN support.