pgsql: Rename jsonb_hash_ops to jsonb_path_ops.

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: pgsql-committers(at)postgresql(dot)org
Subject: pgsql: Rename jsonb_hash_ops to jsonb_path_ops.
Date: 2014-05-11 16:06:09
Message-ID: E1WjWGP-0005Nu-In@gemulon.postgresql.org
Views: Raw Message | Whole Thread | Download mbox | Resend email
Thread:
Lists: pgsql-committers

Rename jsonb_hash_ops to jsonb_path_ops.

There's no longer much pressure to switch the default GIN opclass for
jsonb, but there was still some unhappiness with the name "jsonb_hash_ops",
since hashing is no longer a distinguishing property of that opclass,
and anyway it seems like a relatively minor detail. At the suggestion of
Heikki Linnakangas, we'll use "jsonb_path_ops" instead; that captures the
important characteristic that each index entry depends on the entire path
from the document root to the indexed value.

Also add a user-facing explanation of the implementation properties of
these two opclasses.

Branch
------
master

Details
-------
http://git.postgresql.org/pg/commitdiff/12e611d43e6efbf0e36014a3055ed47366facee7

Modified Files
--------------
doc/src/sgml/gin.sgml | 4 +--
doc/src/sgml/json.sgml | 45 +++++++++++++++++++++++++++++----
src/backend/utils/adt/jsonb_gin.c | 27 ++++++++++----------
src/include/catalog/catversion.h | 2 +-
src/include/catalog/pg_amop.h | 6 ++---
src/include/catalog/pg_opclass.h | 2 +-
src/include/catalog/pg_opfamily.h | 4 +--
src/include/catalog/pg_proc.h | 8 +++---
src/include/utils/jsonb.h | 12 ++++-----
src/test/regress/expected/jsonb.out | 4 +--
src/test/regress/expected/jsonb_1.out | 4 +--
src/test/regress/sql/jsonb.sql | 4 +--
12 files changed, 78 insertions(+), 44 deletions(-)

Browse pgsql-committers by date

  From Date Subject
Next Message Tom Lane 2014-05-11 19:13:36 pgsql: Find postgresql.auto.conf in PGDATA even when postgresql.conf is
Previous Message Peter Eisentraut 2014-05-11 02:17:19 pgsql: Translation updates