From: | vignesh C <vignesh21(at)gmail(dot)com> |
---|---|
To: | Peter Smith <smithpb2250(at)gmail(dot)com> |
Cc: | Amit Kapila <amit(dot)kapila16(at)gmail(dot)com>, Shubham Khanna <khannashubham1197(at)gmail(dot)com>, "Hayato Kuroda (Fujitsu)" <kuroda(dot)hayato(at)fujitsu(dot)com>, "David G(dot) Johnston" <david(dot)g(dot)johnston(at)gmail(dot)com>, Euler Taveira <euler(at)eulerto(dot)com>, Nisha Moond <nisha(dot)moond412(at)gmail(dot)com>, Shlok Kyal <shlok(dot)kyal(dot)oss(at)gmail(dot)com>, PostgreSQL Hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org> |
Subject: | Re: Adding a '--clean-publisher-objects' option to 'pg_createsubscriber' utility. |
Date: | 2025-04-03 08:50:33 |
Message-ID: | CALDaNm0rft_vLRZoR+fps3XdqsXcgRAkgyDKRA8vuvx8CnC2Kw@mail.gmail.com |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
On Thu, 3 Apr 2025 at 09:07, Peter Smith <smithpb2250(at)gmail(dot)com> wrote:
>
> Hi,
>
> I was away for the last few weeks when this feature got committed, so
> I missed the chance to post my comments earlier.
>
> It seems the final SGML docs are mostly from this [1] suggestion, but
> I think there are one or two more improvements that can be made to it:
>
> ======
>
> 1.
> It is not at all obvious from the current Options syntax that
> -R/--remove must take a value.
> A <replaceable>objtype</replaceable> should be included here to address that.
>
> Also, putting the "publications" as a <listitem> renders the HTML
> better IMO, making it way easier to recognize that "publications" is
> an object type, and also making future object types easier to add.
>
> ~
>
> 2. markup
> Use SGML <option> markup for --dry-run
> Use SGML <application> markup for pg_dump
> Use SGML <literal> markup for the specific object type value "publications"
>
> ~
>
> 3.
> Instead of "all tables" publications, we can call these FOR ALL TABLES
> publications. That will be consistent with the Notes later on this
> page.
>
> ~
>
> 4.
> "are individually logged and do show up in a --dry-run"
>
> I felt that "and do show up" is really just another way of saying "logged".
> So, maybe reword this to say "are individually logged, including
> during a --dry-run"
>
> ~~~
>
> Please find attached a small patch that implements all these changes.
Thanks for the patch, the changes look good to me.
Regards,
Vignesh
From | Date | Subject | |
---|---|---|---|
Next Message | jian he | 2025-04-03 08:53:02 | Re: in BeginCopyTo make materialized view using COPY TO instead of COPY (query). |
Previous Message | wenhui qiu | 2025-04-03 08:25:15 | Re: AIX support |