From: | shveta malik <shveta(dot)malik(at)gmail(dot)com> |
---|---|
To: | Bharath Rupireddy <bharath(dot)rupireddyforpostgres(at)gmail(dot)com> |
Cc: | Amit Kapila <amit(dot)kapila16(at)gmail(dot)com>, Bertrand Drouvot <bertranddrouvot(dot)pg(at)gmail(dot)com>, Nathan Bossart <nathandbossart(at)gmail(dot)com>, PostgreSQL Hackers <pgsql-hackers(at)lists(dot)postgresql(dot)org>, shveta malik <shveta(dot)malik(at)gmail(dot)com> |
Subject: | Re: Introduce XID age and inactive timeout based replication slot invalidation |
Date: | 2024-03-25 05:03:30 |
Message-ID: | CAJpy0uA-gJp=aoH+=1jYvU4mZYt4vJCe=cmNn50ZLGFUdjB34g@mail.gmail.com |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
On Sun, Mar 24, 2024 at 3:06 PM Bharath Rupireddy
<bharath(dot)rupireddyforpostgres(at)gmail(dot)com> wrote:
>
> I've attached the v18 patch set here.
Thanks for the patches. Please find few comments:
patch 001:
--------
1)
slot.h:
+ /* The time at which this slot become inactive */
+ TimestampTz last_inactive_time;
become -->became
---------
patch 002:
2)
slotsync.c:
ReplicationSlotCreate(remote_slot->name, true, RS_TEMPORARY,
remote_slot->two_phase,
remote_slot->failover,
- true);
+ true, 0);
+ slot->data.inactive_timeout = remote_slot->inactive_timeout;
Is there a reason we are not passing 'remote_slot->inactive_timeout'
to ReplicationSlotCreate() directly?
---------
3)
slotfuncs.c
pg_create_logical_replication_slot():
+ int inactive_timeout = PG_GETARG_INT32(5);
Can we mention here that timeout is in seconds either in comment or
rename variable to inactive_timeout_secs?
Please do this for create_physical_replication_slot(),
create_logical_replication_slot(),
pg_create_physical_replication_slot() as well.
---------
4)
+ int inactive_timeout; /* The amount of time in seconds the slot
+ * is allowed to be inactive. */
} LogicalSlotInfo;
Do we need to mention "before getting invalided" like other places
(in last patch)?
----------
5)
Same at these two places. "before getting invalided" to be added in
the last patch otherwise the info is incompleted.
+
+ /* The amount of time in seconds the slot is allowed to be inactive */
+ int inactive_timeout;
} ReplicationSlotPersistentData;
+ * inactive_timeout: The amount of time in seconds the slot is allowed to be
+ * inactive.
*/
void
ReplicationSlotCreate(const char *name, bool db_specific,
Same here. "before getting invalidated" ?
--------
Reviewing more..
thanks
Shveta
From | Date | Subject | |
---|---|---|---|
Next Message | Masahiko Sawada | 2024-03-25 05:11:40 | Re: Add new error_action COPY ON_ERROR "log" |
Previous Message | jian he | 2024-03-25 05:00:00 | Re: Improve readability by using designated initializers when possible |