> > > For most places it'd probably end up being easier to read and to
> > > optimize if we just wrote them as
> > > if (unlikely(isinf(result)) && !isinf(arg))
> > > float_overflow_error();
> > > and when needed added a
> > > else if (unlikely(result == 0) && arg1 != 0.0)
> > > float_underflow_error();
> >
> > +1
>
> Cool. Emre, any chance you could write a patch along those lines?
Yes, I am happy to do. It makes more sense to me too.