On 22.02.2007, at 15:56, Jim Nasby wrote:
> and "surrogate key fields should be named 'id'" (I *much* prefer
> the form "object_id", ie: user_id, used *everywhere*, including the
> user table (in that example)).
> Fortunately, with rails extensibility it shouldn't be hard to
> change those default behaviors (in fact there's probably a patch
> somewhere for the first case...)
It's really not hard to use the integrated mechanism for that:
class MyTable < ActiveRecord::Base
set_primary_key "mytable_id"
end
There are nevertheless usage glitches as far as I know. But it's no
real problem.
cug