David,
> However, I am not so keen on the function names. They all start with
> json_! This mostly feels redundant to me, since the types of the
> parameters are part of the function signature.
I have no opinion about starting the function names with json_ or not.
If we decide not, I agree that in general your proposed names are
reasonable. Except:
> json_populate_record()
> record() or row()
> json_populate_recordset() records() or
> rows()
Given that row() is already a type-agnostic function, and RECORD is a
stored procedure return meta-type, I think the above names would be a
mistake. I'd suggest instead:
json_to_record() and json_to_recordset()
or:
to_record(json) and to_recordset(json)
--
Josh Berkus
PostgreSQL Experts Inc.
http://pgexperts.com