Re: Memo on dropping practices

From: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
To: Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us>
Cc: Rod Taylor <rbt(at)zort(dot)ca>, pgsql-hackers(at)postgresql(dot)org
Subject: Re: Memo on dropping practices
Date: 2002-07-13 16:53:16
Message-ID: 3840.1026579196@sss.pgh.pa.us
Views: Raw Message | Whole Thread | Download mbox | Resend email
Thread:
Lists: pgsql-hackers

Bruce Momjian <pgman(at)candle(dot)pha(dot)pa(dot)us> writes:
>> The correct thing to do is to call performDeletion() with a parameter

> Should it be called performDrop rather than Deletion?

Well, if you want to rationalize the naming of these various routines:

I think DROP ought to be associated with the SQL-level commands.
performDeletion is the next level down (since it doesn't do any
permissions checks) and then there are the bottom-level deletion
routines for each object type (which do even less). It would make sense
to choose different verbs for each level. Right now, since I just split
RemoveFoo into two routines and called the second one RemoveFooById,
it's not very mnemonic at all. Perhaps:

DropFoo --- top level, corresponds to SQL DROP command

performSomething -- dependency controller

RemoveFoo --- bottom level deleter

Not sure what "performSomething" should be called, but I'd like to
think of a verb that's not either Drop or Remove. I'm not wedded to
Remove for the bottom level, either. Thoughts?

regards, tom lane

In response to

Responses

Browse pgsql-hackers by date

  From Date Subject
Next Message Tom Lane 2002-07-13 17:03:55 Re: Unique and Primary Key Constraints
Previous Message Bruce Momjian 2002-07-13 15:11:40 Re: Unique and Primary Key Constraints