From: | Peter Eisentraut <peter_e(at)gmx(dot)net> |
---|---|
To: | pgsql-hackers(at)postgresql(dot)org |
Cc: | Thomas Hallgren <thomas(at)tada(dot)se> |
Subject: | Re: What's with this lib suffix? |
Date: | 2006-02-25 13:02:15 |
Message-ID: | 200602251402.17191.peter_e@gmx.net |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
Thomas Hallgren wrote:
> # Default shlib naming convention used by the majority of platforms
> shlib =
> lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
> shlib_major = lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
> shlib_bare = lib$(NAME)$(DLSUFFIX)
>
> and sure enough, that's what gets used too. So what goes?
You are confusing the naming convention for shared libraries that are
intended to be linked into programs (or other libraries) at build time,
which normally have to be named libsomething.so because that is what
the compiler/linker flag -lsomething resolves to, with the naming
convention for shared libraries that are intended to be loaded at
run-time (sometimes called plug-ins), which require no particular
naming.
Examples:
$ ls -1 /usr/lib/postgresql/8.1/lib/
ascii_and_mic.so
cyrillic_and_mic.so
euc_cn_and_mic.so
euc_jp_and_sjis.so
euc_kr_and_mic.so
euc_tw_and_big5.so
latin2_and_win1250.so
latin_and_mic.so
pljava.so
plpgsql.so
...
$ ls -1 /usr/lib/samba/vfs/
audit.so
cap.so
default_quota.so
expand_msdfs.so
extd_audit.so
fake_perms.so
full_audit.so
netatalk.so
readonly.so
recycle.so
shadow_copy.so
$ ls -1 /lib/security/
pam_access.so
pam_debug.so
pam_deny.so
pam_env.so
pam_filter.so
pam_ftp.so
...
$ ls -1 /usr/lib/apache2/modules/
httpd.exp
mod_actions.so
mod_asis.so
mod_auth_anon.so
mod_auth_dbm.so
mod_auth_digest.so
mod_auth_ldap.so
mod_cache.so
...
$ ls -1 /usr/lib/valgrind/x86-linux/
...
vgpreload_core.so
vgpreload_helgrind.so
vgpreload_massif.so
vgpreload_memcheck.so
--
Peter Eisentraut
http://developer.postgresql.org/~petere/
From | Date | Subject | |
---|---|---|---|
Next Message | Thomas Hallgren | 2006-02-25 13:20:36 | Re: What's with this lib suffix? |
Previous Message | Martin Pitt | 2006-02-25 12:46:48 | Re: Adding an ignore list to pg_restore, prototype patch #1 |