This patch removes a few instances where a pointer type was being
explicitly cast to void * when pfree() was called. Per ANSI89, this is
redundant: any pointer type can be assigned to void *, and vice versa,
without a cast. IMHO adding the cast in this case serves only to make
the code harder to read.
Would anyone object to me removing some more void * casts, e.g. the
parameters to the various _walker functions?
-Neil