From: | Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> |
---|---|
To: | Andres Freund <andres(at)anarazel(dot)de> |
Cc: | pgsql-hackers(at)lists(dot)postgresql(dot)org |
Subject: | Re: POC: converting Lists into arrays |
Date: | 2019-02-27 20:26:46 |
Message-ID: | 10893.1551299206@sss.pgh.pa.us |
Views: | Raw Message | Whole Thread | Download mbox | Resend email |
Thread: | |
Lists: | pgsql-hackers |
I wrote:
> I did find a number of places where getting rid of explicit lnext()
> calls led to just plain cleaner code. Most of these were places that
> could be using forboth() or forthree() and just weren't. There's
> also several places that are crying out for a forfour() macro, so
> I'm not sure why we've stubbornly refused to provide it. I'm a bit
> inclined to just fix those things in the name of code readability,
> independent of this patch.
0001 below does this. I found a couple of places that could use
forfive(), as well. I think this is a clear legibility and
error-proofing win, and we should just push it.
> I also noticed that there's quite a lot of places that are testing
> lnext(cell) for being NULL or not. What that really means is whether
> this cell is last in the list or not, so maybe readability would be
> improved by defining a macro along the lines of list_cell_is_last().
> Any thoughts about that?
0002 below does this. I'm having a hard time deciding whether this
part is a good idea or just code churn. It might be more readable
(especially to newbies) but I can't evaluate that very objectively.
I'm particularly unsure about whether we need two macros; though the
way I initially tried it with just list_cell_is_last() seemed kind of
double-negatively confusing in the places where the test needs to be
not-last. Also, are these macro names too long, and if so what would
be better?
Also: if we accept either or both of these, should we back-patch the
macro additions, so that these new macros will be available for use
in back-patched code? I'm not sure that forfour/forfive have enough
use-cases to worry about that; but the is-last macros would have a
better case for that, I think.
regards, tom lane
Attachment | Content-Type | Size |
---|---|---|
0001-use-forboth-etc-in-more-places.patch | text/x-diff | 14.5 KB |
0002-add-list-cell-is-last-macros.patch | text/x-diff | 10.2 KB |
From | Date | Subject | |
---|---|---|---|
Next Message | Robert Haas | 2019-02-27 20:32:57 | Re: POC: converting Lists into arrays |
Previous Message | Alvaro Herrera | 2019-02-27 19:31:14 | Re: Update does not move row across foreign partitions in v11 |